Stores Access Issues – Resolution in Progress

Incident Report for Zid

Resolved

Our stores are back online! Our team has successfully handled the issue, and we are now in the monitoring phase to ensure everything runs smoothly.
Posted Feb 18, 2025 - 14:12 GMT+03:00

Identified

Our stores are currently experiencing downtime. We’re actively working on resolving the issue and will keep you updated on the progress.

Thank you for your patience! 🙏
Posted Feb 18, 2025 - 13:40 GMT+03:00
This incident affected: Stores.